Initial ODA Setup – Bare Metal (non-virtualized)

Older info but wanted to post anyway, I created this in 2013

Initial ODA Setup – Bare Metal (non-virtualized)

Oracle Database Appliance – 2.X Supported Versions & Known Issues (Doc ID 888888.1)
https://support.oracle.com/epmos/faces/SearchDocDisplay?_adf.ctrl-state=ub5o8i5pd_9&_afrLoop=125861182934599

Setup Host 1: From server node 0, run the validate script to confirm that the cabling is correct:

[root@oak1 bin]# /opt/oracle/oak/bin/oakcli validate -c storageTopology
It may take a while. Please wait…
INFO : ODA Topology Verification
INFO : Running on Node0
INFO : Check hardware type
SUCCESS : Type of hardware found : X3-2
INFO : Check for Environment(Bare Metal or Virtual Machine)
SUCCESS : Type of environment found : Bare Metal
INFO : Check number of Controllers
SUCCESS : Number of Internal LSI SAS controller found : 1
SUCCESS : Number of External LSI SAS controller found : 2
INFO : Check for Controllers correct PCIe slot address
SUCCESS : Internal LSI SAS controller : 50:00.0
SUCCESS : External LSI SAS controller 0 : 30:00.0
SUCCESS : External LSI SAS controller 1 : 40:00.0
INFO : Check if JBOD powered on
SUCCESS : 1JBOD : Powered-on
INFO : Check for correct number of EBODS(2 or 4)
SUCCESS : EBOD found : 2
INFO : Check for External Controller 0
SUCCESS : Controller connected to correct ebod number
SUCCESS : Controller port connected to correct ebod port
SUCCESS : Overall Cable check for controller 0
INFO : Check for External Controller 1
SUCCESS : Controller connected to correct ebod number
SUCCESS : Controller port connected to correct ebod port
SUCCESS : Overall Cable check for controller 1
INFO : Check for overall status of cable validation on Node0
SUCCESS : Overall Cable Validation on Node0
INFO : Check Node Identification status
SUCCESS : Node Identification
SUCCESS : Node name based on cable configuration found : NODE0
INFO : Check JBOD Nickname
SUCCESS : JBOD Nickname set correctly : Oracle Database Appliance - E0
INFO : The details for Storage Topology Validation can also be found in log file=/opt/oracle/oak/log/oak1/storagetopology/StorageTopology-2013-12-13-23:02:30_26430_31293.log

Setup network for host

[root@oak1 bin]# /opt/oracle/oak/bin/oakcli configure firstnet
INFO: Non VM environment detected
Select the interface to configure network on (bond0 bond1) [bond0]:
Configure DHCP on bond0 (yes/no) [no]:
INFO: Static configuration selected
Enter the IP address to configure:10.250.132.140
Enter the netmask address to configure:255.255.255.0
Enter the gateway address to configure[10.250.132.1]:
INFO: Plumbing the IPs now
Loading kernel module for a network device with CAP_SYS_MODULE (deprecated). Use CAP_NET_ADMIN and alias netdev-icbond0 instead
INFO: Restarting the network
Shutting down interface bond0: bonding: bond0: Warning: the permanent HWaddr of eth2 - 00:10:e0:32:39:74 - is still in use by bond0. Set the HWaddr of eth2 to a different address to avoid conflicts.
bond0: mixed no checksumming and other settings.
[ OK ]
Shutting down interface bond1: bonding: bond1: Warning: the permanent HWaddr of eth4 - 00:10:e0:32:39:76 - is still in use by bond1. Set the HWaddr of eth4 to a different address to avoid conflicts.
bond1: mixed no checksumming and other settings.
[ OK ]
Shutting down interface eth0: [ OK ]
Shutting down interface eth1: [ OK ]
Shutting down loopback interface: [ OK ]
Bringing up loopback interface: [ OK ]
Bringing up interface bond0: [ OK ]
Bringing up interface bond1: [ OK ]
Bringing up interface eth0: [ OK ]
Bringing up interface eth1: [ OK ]
[root@oak1 bin]# ifconfig -a
bond0 Link encap:Ethernet HWaddr 00:10:E0:32:39:74
inet addr:10.250.132.140 Bcast:10.250.132.255 Mask:255.255.255.0
inet6 addr: fe80::210:e0ff:fe32:3974/64 Scope:Link
UP BROADCAST RUNNING MASTER MULTICAST MTU:1500 Metric:1
RX packets:213749 errors:0 dropped:106875 overruns:0 frame:0
TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:15626616 (14.9 MiB) TX bytes:1744 (1.7 KiB)

Check versions

[root@oak1 media]# /opt/oracle/oak/bin/oakcli show version -detail
Reading the metadata. It takes a while…
System Version Component Name Installed Version Supported Version

2.7.0.0.0
Controller_INT 11.05.02.00 Up-to-date
Controller_EXT 11.05.02.00 Up-to-date
Expander 000F Up-to-date
SSD_SHARED 9432 Up-to-date
HDD_LOCAL A31A Up-to-date
HDD_SHARED A31A Up-to-date
ILOM 3.1.2.10 r74387 Up-to-date
BIOS 17021300 Up-to-date
IPMI 1.8.10.5 Up-to-date
HMP 2.2.6.2 Up-to-date
OAK 2.7.0.0.0 Up-to-date
OEL 5.9 Up-to-date
[root@oak1 ODA-X3-2]# /opt/oracle/oak/bin/oakcli unpack -package /mnt/media/ODA-X3-2/ISOs/p12978712_27000_Linux-x86-64.zip
Unpacking takes a while, pls wait….
Successfully unpacked the files to repository.
Setup Host 2
[root@oak2 ~]# /opt/oracle/oak/bin/oakcli configure firstnet
INFO: Non VM environment detected
Select the interface to configure network on (bond0 bond1) [bond0]:
Configure DHCP on bond0 (yes/no) [no]:
INFO: Static configuration selected
Enter the IP address to configure:10.250.132.141
Enter the netmask address to configure:255.255.255.0
Enter the gateway address to configure[10.250.132.1]:
INFO: Plumbing the IPs now
Loading kernel module for a network device with CAP_SYS_MODULE (deprecated). Use CAP_NET_ADMIN and alias netdev-icbond0 instead
INFO: Restarting the network
Shutting down interface bond0: bonding: bond0: Warning: the permanent HWaddr of eth2 - 00:10:e0:32:3b:72 - is still in use by bond0. Set the HWaddr of eth2 to a different address to avoid conflicts.
bond0: mixed no checksumming and other settings.
[ OK ]
Shutting down interface bond1: bonding: bond1: Warning: the permanent HWaddr of eth4 - 00:10:e0:32:3b:74 - is still in use by bond1. Set the HWaddr of eth4 to a different address to avoid conflicts.
bond1: mixed no checksumming and other settings.
[ OK ]
Shutting down interface eth0: [ OK ]
Shutting down interface eth1: [ OK ]
Shutting down loopback interface: [ OK ]
Bringing up loopback interface: [ OK ]
Bringing up interface bond0: [ OK ]
Bringing up interface bond1: [ OK ]
Bringing up interface eth0: [ OK ]
Bringing up interface eth1: [ OK ]

Configure Oracle Appliance Manager

[root@oak1 ~]# cd /opt/oracle/oak/bin
[root@oak1 bin]# ./oakcli deploy
Log messages in /tmp/oak_1387007395121.log
Running Oracle Appliance Manager
Make sure and save your config
When it get to 100% and no errors then we are done

Post install Check

You should notice new items that were not present when this was done earlier.

[root@tecoda1 bin]# oakcli show version -detail
Reading the metadata. It takes a while…
System Version Component Name Installed Version Supported Version

2.7.0.0.0
Controller_INT 11.05.02.00 Up-to-date
Controller_EXT 11.05.02.00 Up-to-date
Expander 000F Up-to-date
SSD_SHARED 9432 Up-to-date
HDD_LOCAL A31A Up-to-date
HDD_SHARED A31A Up-to-date
ILOM 3.1.2.10 r74387 Up-to-date
BIOS 17021300 Up-to-date
IPMI 1.8.10.5 Up-to-date
HMP 2.2.6.2 Up-to-date
OAK 2.7.0.0.0 Up-to-date
OEL 5.9 Up-to-date
TFA 2.5.1.5 Up-to-date
GI_HOME 11.2.0.3.7(16619892, Up-to-date
16742216)
DB_HOME 11.2.0.3.7(16619892, Up-to-date
16742216)

Upgrade to new Oak revision

Previous

[root@tecoda1 ~]# uname -a
Linux tecoda1 2.6.39-400.111.1.el5uek #1 SMP Fri Jun 7 18:53:16 PDT 2013 x86_64 x86_64 x86_64 GNU/Linux